Would you like to react to this message? Create an account in a few clicks or log in to continue.

Chess4uLog in

Welcome to the chess for you Forum.chess for you is a place to discuss and share anything related a Computer Chess.Join A Community That Cares About You.

Free Chess Opening Book for Every 15 Days

descriptionWinboard [Alien Edition] EmptyWinboard [Alien Edition]

[You must be registered and logged in to see this image.]

Download WinBoard Alien Edition (including simplistic Dark-Chess engine!)Source repository (git)
Nebiyu Engine by Daniel Shawul

WinBoard Alien Edition
- Experimental version of WinBoard that has some enhancements to facilitate its use as GUI
- Enter multiple moves per turn (by keeping the control key pressed to suppress the turn change, or suffixing the move with a comma in text mode)
- New "variant dark" that implements "Dark Chess". Here the board is partly blacked-out when you are playing an engine, as well are moves and PVs
- New "variant amazons"

descriptionWinboard [Alien Edition] EmptyRe: Winboard [Alien Edition]

XBoard and WinBoard, bugs and problems
[You must be registered and logged in to see this link.]
Troubleshooting strategy

- I can't build XBoard because the X11/Xaw/... include files are not found
[Hide]These are the header files for the Athena Widgets library, which XBoard uses heavily. Some versions of Unix don't supply these files, but they are part of the standard X distribution, freely available from MIT.
For general information on getting missing X sources, see the FAQ on Note that you may be missing only the header files, or you may be missing the libraries themselves too.
HP-UX users are missing only the header files. You can get them by anonymous FTP as follows. (But first check with your system administrator to see if someone else at your site has already done this.) Get the archive file /hpux9/X11R5/Core/Xaw-5.00.tar.gz (Xaw header files) via anonymous FTP from the site (, or one of the other official sites---Germany: (, US: (, France: ( or Netherlands: ( Unpack the archive using gzip and follow the instructions in its README and/or HPUX.Install files. Thanks to Richard Lloyd for this information.
If you have the Xaw header files installed in a different place than the other X11 headers, you may need to configure XBoard with an extra flag to help it find them.
- Configuring or building XBoard fails due to missing header files, missing libraries, or undefined symbols.
[Hide]Perhaps you have the X server and client programs installed on your machine, but not the X header files and link-time libraries. If so, you can run existing X programs, but you cannot compile a new X program from source code. In this case the XBoard configure script will fail and will tell you to look at this question in the FAQ. Many GNU/Linux distributions put the headers and libraries in a separate package, which you might not have installed. If you are using RedHat, install the XFree86-devel package. If you are using some other kind of Unix, ask your system administrator where to find the X header files and link-time libraries. If this is not your problem, read on.
The configure script for XBoard looks for X libraries and header files in some common places. Sometimes it fails: If yours are installed in an odd place, it may not find them at all. If you have more than one version of X installed on your system, it may find the "wrong" one, or occasionally it may find libraries from one version and incompatible header files from another. You can work around these problems by telling the configure script where the files are. For example:
   configure --x-includes=/odd/place/include \
The directory named in the argument to --x-includes must have a subdirectory "X11" that contains the actual .h files. That is, if your X.h file has full pathname /odd/place/X11R6/include/X11/X.h, then you must give the argument --x-includes=/odd/place/X11R6/include.
Some linkers have bugs that cause bogus error messages when you try to link X programs. The configure script includes a workaround for a bug of this kind that exists in some SunOS 4.x.x installations. See the FAQ on for more information about problems of this kind.
If all else fails, check whether anyone else at your site has been able to compile any X programs on your system. Your X installation might be buggy. If so, the system administrator at your site might know how to fix or work around the problem.[/Hide]
- I have problems using WinBoard on ICS with a modem. I'm not running SLIP or PPP, but just dialing in to an ordinary login account ("shell account").
[Hide]Here are solutions to some common problems in this area.
Some people want to connect to ICS through HyperTerminal or some other terminal program first, then run WinBoard. This is not how it works. WinBoard wants to talk directly with your modem, acting as a terminal program itself. Start out with the modem "on hook" (not making a call).
Run WinBoard with a command line like this (adding more options if desired):
   WinBoard /ics /icscom com1
Use com2, com3, or com4 in place of com1 if your modem is connected to one of those ports.
After you start WinBoard, you may need to change some of the options in the Communications dialog (on the Options menu). The dialog has the usual options for talking to modems: bits per second, bits per byte, parity, number of stop bits. You will probably want to use Save Settings Now when you're done.
Next, type dialing commands to your modem in the text window that WinBoard creates. You may need to turn off Local Line Editing on the Options menu while you are typing commands to your modem. Turn it back on when you're done. See the WinBoard Help file for instructions if you see your typing echoed an extra time after you hit Enter.[/Hide]
- I have problems using WinBoard on ICS with Windows 95 and SLIP or PPP. When trying to start up, it gets the error "Address family not supported by protocol family" (or some equally strange message).
[Hide]WinBoard is a 32-bit application, but some Winsock (TCP/IP) implementations support only 16-bit applications. You get a strange looking error message if you try to use a 32-bit application because there is no standard Winsock error code number for "32-bit application not supported."
Microsoft TCP/IP works with both 16-bit and 32-bit applications, supports SLIP, PPP, Ethernet, etc., and is included with Windows 95 and later Windows systems. If possible, I recommend that you uninstall whatever Winsock you are using and install Microsoft TCP/IP instead. For more information, see [You must be registered and logged in to see this link.] (the Win95-L FAQ).
Trumpet Winsock 2.1 (and earlier) supports only 16-bit applications, and hence does not work with WinBoard. But there is a beta-test release available that does support 32-bit applications. I have not tried it with WinBoard, but it should work. See Trumpet's Web page [You must be registered and logged in to see this link.] for more information.
The 16-bit versions of America On-Line's software do not support 32-bit Winsock applications. Get the 32-bit version. At one time the 32-bit version was called "AOL for Windows 95," but I imagine that has changed. Hopefully the current versions are all 32-bit.
A few versions of Winsock may have bugs that prevent Windows timestamp/timeseal from working with them. I'm not sure if such bugs exist in any versions that actually have 32-bit support, so this point might be moot. Again, Microsoft TCP/IP is known to work.[/Hide]
- When I try to run WinBoard, I get the message "Failed to start chess program gnuchess on localhost: NO LANGFILE (file gnuchess.lan not found)".
[Hide]This message means that WinBoard is trying to run GNU Chess, but GNU Chess cannot find a file that it needs, named gnuchess.lan. If you see it, you've probably customized WinBoard's /fcp, /fd, /scp, and/or /sd options and made a mistake in the process. Review what you did, and see the WinBoard help file.[/Hide]
- I want to use XBoard or WinBoard as an Internet Chess Server interface, but the ICS Client option is grayed out on the menu.
[Hide]XBoard and WinBoard have three major modes that can't be changed from the menus: local chess engine mode, ICS mode, and standalone mode.
With XBoard, you have to set the mode using command-line options. Local chess engine mode is the default, -ics selects ICS mode, and -ncp ("no chess program") selects standalone mode.
With WinBoard, if you don't set the mode using command-line options, you get a dialog box asking which mode you want. To bypass the dialog box, use -cp ("chess program") for local chess engine mode, or -ics or -ncp as with XBoard.[/Hide]
- How do I give command-line options to a Windows program like WinBoard?
[Hide]There are many ways; pick your favorite:
Type the command line into an MS-DOS Prompt box. Example: "WinBoard -ics".
Make a Windows shortcut for WinBoard. You can do this by right-dragging WinBoard.exe to the desktop and selecting "Create Shortcut(s) Here" from the menu that appears. Right-click on the shortcut, select Properties, and click the Shortcut tab. The command-line text box is labelled "Target" instead of "Command line" just to confuse you. Edit the text in this box, adding the command line options to the end.
Choose Run from the Start menu, or File / Run from the Program Manager or File Manager, and type the command line into the dialog you get. You may have to give WinBoard's full drivespec and filename if it is not in a directory on your search path.
Make a Program Manager icon for WinBoard. You can do this by dragging WinBoard.exe from the File Manager into the Program Manager, or by using File / New in the Program Manager. Select the icon and choose File / Properties. Edit the Command Line text box to add the command-line options to the end.[/Hide]
- When I exit from WinBoard after using it to play against a chess program on my machine, the chess program keeps running in the background.
[Hide]Be sure you have the current versions of WinBoard and the chess engine you are using. WinBoard 3.4.1 and earlier had a bug that caused this problem to occur with all chess engines. A buggy chess engine that does not respond to the "quit" command will also cause this.
If you still see this problem, you can stop the rogue chess engine by pressing Ctrl+Alt+Del, selecting the chess engine process from the menu, and pressing the End Task button.[/Hide]
- Why do my ICS opponents often get extra time after they make their moves? Why do I sometimes lose time off my clock after I make my move?
[Hide]If you are playing with the ICS incremental clock, both you and your opponent get a set amount of extra time after each move.
If your or your opponent has netlag, your opponent might appear to get extra time, especially if your opponent is using timestamp or timeseal. The ICS charges each player who is using timestamp or timeseal only for the time between when the player received his opponent's move and the time he sent his own move. Thus delays in network transmission do not count against either player. But WinBoard counts down the display of your opponent's clock on your screen under the assumption that there is no netlag. When his move comes in, if there was netlag, the ICS may not have really charged him for that much time, and WinBoard corrects the clock to what the ICS says it should read.
If you are not using timestamp or timeseal, you may appear to lose time off your clock at some point after you make your move. In this case, the ICS charges you for the time between when it sent you your opponent's move and the time it received your move. Thus delays in network transmission count against you. WinBoard stops counting down the display of your clock on your screen (and starts your opponent's) when you make your move. When the ICS echoes your move back to you, it may have charged you for more time than that, and WinBoard corrects the clocks to what the ICS says they should read.
See "help lag" and "help timestamp" or "help timeseal" on your ICS for more detailed information.[/Hide]
- I can't run WinBoard unless I delete the WinBoard.ini file each time!
[Hide]Most people don't have this problem, but two or three people using Windows NT 4.0 with Service Pack 3 or 4 have reported it. I have no idea what causes this problem. Contrary to what was reported in a previous version of this FAQ, reinstalling the service pack after installing WinBoard does not seem to solve the problem.[/Hide]
- I get errors compiling XBoard's parser.c.
[Hide]The file parser.c is automatically generated from parser.l. The copy included with XBoard 4.0.2 was generated by lex on Tru64 Unix and has problems compiling and linking on current GNU/Linux versions. The copy included with XBoard 4.0.3 was generated by flex on a GNU/Linux machine, but it too won't necessarily work on other versions of Unix. If you have this problem, you can fix it by deleting parser.c and letting the Makefile re-create it from parser.l. This will work if you have either lex or flex on your system. Flex is available in all GNU/Linux distributions and can be obtained at no charge from the Free Software Foundation, [You must be registered and logged in to see this link.] [/Hide]
- I get an error building WinBoard from source because "flex" is not found.
[Hide]The file parser.c is automatically generated from parser.l. The Makefile included with the WinBoard source kit has a rule for generating parser.c using the program "flex", which will fail if you don't have flex. However, the source kit also includes a ready-made copy of parser.c, so you don't really need flex unless you have made changes to parser.l. Check that you still have a copy of parser.c; if you don't, unpack the WinBoard source zip file again to get one. Either set the last-modified time of parser.c to be later than that of parser.l, delete parser.l, or comment out the Makefile rule for building parser.c from parser.l, and then try building WinBoard again.
If you do want to change parser.l and rebuild parser.c, you can get flex as part of the free Cygwin kit from [You must be registered and logged in to see this link.] You can probably also get flex for Windows by itself from various other places around the Internet. It is free software distributed by the Free Software Foundation.[/Hide]
- XBoard hangs shortly after connecting to an ICS when used with dxterm, cmdtool, dtterm, kterm, konsole, or other substitutes for xterm.
[Hide]After connecting to a chess server, XBoard 4.0.2 and later sends an escape sequence to its terminal that is meant to display your handle and the ICS host name (for example, "") in the terminal's banner and icon. It seems that several of the alternative X terminal programs have a bug that makes them hang when sent this escape sequence.
You can work around the problem by using xterm, nxterm, rxvt, aterm, xiterm, or gnome-terminal, all of which seem to work fine. In fact, current versions of kterm and konsole seem to work fine too, so if you are having problems with one of them, be sure you are not running an outdated version.
Alternatively, you can disable this feature by commenting out the body of DisplayIcsInteractionTitle in xboard.c and recompling xboard.[/Hide]
- The WinBoard pieces show up in the wrong colors, appear distorted, or are not visible at all.
[Hide]This can happen if you have a bug in your Windows display driver. Check with the manufacturer of your display card, the manufacturer of your computer, or Microsoft to see if there is an updated driver available. You can usually download updated drivers from the Web.
If you can't find an updated driver, you can try running Windows using a different number of colors and/or disabling some of the hardware acceleration features on your display card. To change the number of colors, go to Windows Start / Settings / Control Panel / Display / Settings / Color Palette. To disable hardware acceleration features, go to Windows Start / Settings / Control Panel / Display / Settings / Advanced Properties / Performance / Hardware Acceleration.
It's also possible that Windows has the right driver for your hardware already but you are not using it. It may help to reinstall your driver. Go to Windows Start / Settings / Control Panel / System and delete your display card (maybe even your monitor too), then reboot. Windows should automatically re-detect your card and monitor and re-install the drivers; if it doesn't, run Start / Settings / Control Panel / Add New Hardware to force it to.
If all else fails, try Monochrome mode. On WinBoard's menus, go to Options / Color and check Monochrome. WinBoard will display in black and white.[/Hide]
- XBoard or WinBoard tells me "Error: first chess program (...) exited unexpectedly".
[Hide]This message means that your chess engine crashed, probably due to a bug in the engine, or because you have it configured incorrectly. You can try running XBoard or WinBoard again with the "-debug" flag on the command line. This will print out all the messages received from the chess engine. (With WinBoard, the messages go into a file called WinBoard.debug; with XBoard, they go to the xterm that you started XBoard from.)
If you are using GNU Chess and you see this problem as soon as it starts up, most likely GNU Chess is exiting with an error message. If you see the message "NO LANGFILE", it means that you did not install GNU Chess correctly, and it is unable to find the file gnuchess.lang. Make sure that you defined LIBDIR in the gnuchess Makefile, and that gnuchess.lang is in that directory. If gnuchess.lang is not there, you probably didn't type "make install" in the gnuchess src directory; you must do this to install gnuchess.lang (and the gnuchess book). If you defined LIBDIR to something that is not an absolute pathname (that is, to something that does not start with a "/"), GNU Chess will work only if you run it from the GNU Chess "src" directory where you built it.[/Hide]
- XBoard tells me "Warning: Cannot allocate colormap entry", or "too few colors available; trying monochrome mode", or "XPM pieces cannot be used in monochrome mode".
[Hide]You are running your X server with 8-bit color depth, and you are running some program that has used up all 256 of your colors. Netscape tends to do this, or maybe you have a background image that uses up all of your colors.
If you have a modern machine, you probably have enough display memory to run your X server with 16-, 24-, or 32-bit color depth. If you're using "startx" to start the X server, try giving the command as "startx -- -bpp 24" (or 16, or 32). On newer X servers you may have to use -depth instead of -bpp. Further details on configuring your X server are beyond the scope of this FAQ.
If you must run in 8-bit mode, try the following: Avoid background images that use up all your colors. If you run Netscape, try starting it up with the -install command-line option; this gives Netscape its own private colormap that X will switch to when Netscape has the keyboard focus.
If all else fails, another possibility is to run xboard in monochrome (black and white) mode by giving it the -mono command-line option. XBoard will try this by itself in some cases. Monochrome mode works only with bitmap pieces, not pixmap pieces, so trying to use it may give you the error "XPM pieces cannot be used in monochrome mode". To get around this, either use the -bitmapDirectory command line option to point XBoard to the directory containing the bitmap pieces included with the XBoard source code, or rebuild XBoard with pixmap support disabled, using "./configure --disable-xpm ; make clean ; make".[/Hide]
- When I log in to, the Enter key doesn't work, and I have to use Ctrl+J instead. But when I use WinBoard, Ctrl+J doesn't work either, so I'm stuck.
[Hide]This is a pretty rare problem. It should only arise if you have to reach by telnetting (or connecting with WinBoard /icsport=23) from a Windows PC to a Unix box, and then telnetting from there to The Enter key should always work when connecting directly from your PC to
The best way to get around the problem is to run timeseal on the intermediate Unix box instead of telnet. Get the appropriate version of timeseal for your box from [You must be registered and logged in to see this link.] and follow the directions in the help files on FICS.
If you can't run timeseal for some reason, there are some things you can do to make telnet stay in line mode instead of going to character mode. Then the Enter key will work. First, try "telnet 5000" instead of "telnet" If that still doesn't work, then when the Enter key stops working, type the following. Here < and > surround the names of keys.
   <Ctrl+S><Ctrl+]>mode line<Enter>[/Hide]
- XBoard says, "Failed to start first chess program fairymax on localhost: fairymax: No such file or directory."
[Hide]XBoard is looking for the Fairy-Max chess engine. If you did want to use Fairy-Max, be sure you have it installed and that it is on your $PATH.[/Hide]

descriptionWinboard [Alien Edition] EmptyRe: Winboard [Alien Edition]

WinBoard 4.8.0 beta (new release)
[You must be registered and logged in to see this link.]

descriptionWinboard [Alien Edition] EmptyRe: Winboard [Alien Edition]

privacy_tip Permissions in this forum:
You cannot reply to topics in this forum